Cabin Air Filter - Acura Forum : Acura Forums

1st Gen RL Forum for the 1996-2004 Acura RL

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-14-13, 02:37 PM Thread Starter
Registered User
 
Join Date: Dec 2012
Posts: 8
Cabin Air Filter

My heat/ac doesn't blow hard on high and was wondering if it could be my cabin air filter. If not could it be the fan motor or the electronics of the climate control? It's a 00 RL with 131K and it had the original plugs so I doubt the previous owner changed the filter. How hard is it to replace and where is it located?

Thanks
rowekmr is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 02-15-13, 03:08 PM
Acuraworld Preferred Vendor
 
Hondacuraplanet's Avatar
 
Join Date: Jul 2002
Location: Buffalo, NY USA
Age: 44
Posts: 4,755
Garage
Send a message via AIM to Hondacuraplanet
Doubtful, but worth a look. The access door is right behind the glove box.



Tim Poliniak - ASE Certified Parts Specialist, 21 years with Acura/Honda

Acura of Peoria ~ www.oemacuraparts.com
Hondacuraplanet is offline  
Sponsored Links
Advertisement
 
Reply

  Acura Forum : Acura Forums > Luxury Sedans > RL > 1st Gen RL

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Acura Forum : Acura Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome