Speedometer stopped working, HELP!! 97 RL - Acura Forum : Acura Forums
Acura Forums Acura Forums
 
Go Back   Acura Forum : Acura Forums > Luxury Sedans > RL > 1st Gen RL


1st Gen RL Forum for the 1996-2004 Acura RL

Reply
 
LinkBack Thread Tools Display Modes
Old 03-13-12, 08:16 PM   #1 (permalink)
Registered User
 
Antonio5780's Avatar
 
Join Date: Nov 2003
Location: Oklahoma
Posts: 46
Question Speedometer and Odometer stopped working, HELP!!

Hi guys,

I need your help. My speedometer and odometer stopped working in my 97 RL which has 198,000 miles.

I turned it on last night and the center speedo and odometer didn't work. The tachometer(on left) and the gas, and temperature gauge(on right) still work great.

Any idea what could be the problem?? Any advice would be great. Thank You
__________________
97 Acura 3.5 RL

Last edited by Antonio5780; 03-15-12 at 01:35 PM.
Antonio5780 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Old 03-16-12, 11:13 AM   #2
Acuraworld Preferred Vendor
 
Hondacuraplanet's Avatar
 
Join Date: Jul 2002
Location: Buffalo, NY USA
Age: 43
Posts: 4,533
Garage


Car 1: 2007 Cadillac DTS
The speedometer and odometer drive circuits receive pulses from the vehicle speed sensor
(VSS). The pulse rate increases as the vehicle speed increases. This speed signal is converted and displayed by the speedometer, odometer, and trip meter.

The first thing to do is check for a blown fuse #13 in your fuse box. Beyond that, use this troubleshooting diagram to verify proper operation of the vehicle speed sensor.
Attached Images
File Type: pdf RL9604S23086A.pdf (51.6 KB, 690 views)
__________________


Tim Poliniak - ASE Certified Parts Specialist, 19 years with Acura/Honda

Acura of Peoria ~ www.oemacuraparts.com
Hondacuraplanet is offline   Reply With Quote
Old 03-20-12, 05:20 AM   #3
Registered User
 
Antonio5780's Avatar
 
Join Date: Nov 2003
Location: Oklahoma
Posts: 46
Quote:
Originally Posted by Hondacuraplanet View Post
The speedometer and odometer drive circuits receive pulses from the vehicle speed sensor
(VSS). The pulse rate increases as the vehicle speed increases. This speed signal is converted and displayed by the speedometer, odometer, and trip meter.

The first thing to do is check for a blown fuse #13 in your fuse box. Beyond that, use this troubleshooting diagram to verify proper operation of the vehicle speed sensor.
Thanks for the help Tim.

Well today my speedometer started working again but not the digital odometer and trip meter on the bottom. Any idea if it would be vehicle speed sensor or instrument cluster??

I'm not savvy enough to do the testing in the diagram you showed me.
__________________
97 Acura 3.5 RL
Antonio5780 is offline   Reply With Quote
Old 06-15-12, 09:25 PM   #4
Registered User
 
Join Date: Jun 2012
Posts: 10
My Mood: Relaxed


Car 1: 97 Acura RL
Well today my speedometer started working again but not the digital odometer and trip meter on the bottom. Any idea if it would be vehicle speed sensor or instrument cluster?? [/QUOTE]

I just received word that my board is fried on my cluster on my 97 RL. The place that was supposed to fix it in VA screwed it up worse than before.

Before: No speedo, no odometer, tach worked, gas worked and temp worked.

Now: No speedo, No odometer, no lights in tach side, temp gauge no work, srs light on, engine light on with no codes.

WTH did they do! 576.00 for board and not sure that will fix it.
azimmey1 is offline   Reply With Quote
Old 07-10-14, 12:10 AM   #5
Registered User
 
Join Date: Jul 2014
Posts: 4


Car 1: 1996 Acura 3.5 RL
Car 2: 1991 Acura Integra GS
I just found this email about Odometer being unable to be read, after posting on this same message forum.

Perhaps you can help?
nutech12 is offline   Reply With Quote
Old 07-10-14, 11:14 AM   #6
Acuraworld Preferred Vendor
 
Hondacuraplanet's Avatar
 
Join Date: Jul 2002
Location: Buffalo, NY USA
Age: 43
Posts: 4,533
Garage


Car 1: 2007 Cadillac DTS
There's not much I can say beyond what's posted. Offhand, you'll probably need to replace the odometer board:

PANEL, ODOMETER & TRIPMETER PRINT | Genuine Acura | 78118-SZ3-003
__________________


Tim Poliniak - ASE Certified Parts Specialist, 19 years with Acura/Honda

Acura of Peoria ~ www.oemacuraparts.com
Hondacuraplanet is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Acura Forum : Acura Forums > Luxury Sedans > RL > 1st Gen RL

Tags
speedometer


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



Auto Insurance

» Featured Product
Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 09:02 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
(c) Acuraworld 2006-2009. All rights reserved. Some likenesses, images, and the Acura logo are (TM) American Honda Corporation.Ad Management plugin by RedTyger