dash light problems - Acura Forum : Acura Forums

2nd Gen TL Forum specific to the Acura TL, 1999-2003.

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-31-10, 12:08 AM Thread Starter
Registered User
Join Date: Oct 2010
Location: Schaumburg IL
Posts: 1
dash light problems

I have a 99 acura tl and i put a aftermarket radio in and after that none of my dash lights dont come on and im driveing and cant see how fast im driving i checked my fuses in the car and under the hood and nothing at all i need help i have been reading the forums and looking but i cant fine anything any help with this i would be gratefull i live in the chicago land area incase there are any other tl guys out here
boosted4g63 is offline  
Sponsored Links
post #2 of 4 Old 11-05-10, 09:31 PM
99 TL
Join Date: Nov 2010
Location: PA
Posts: 1
Yo, Got 99Tl Pearl white, Same Problem, Put Alpine Head unit In and bam No dash lights, no clock light Ac/control lights but head units lite up.... Mine even goes as far as the exterior lights working differently. Parking lights always on... And now when I turn The car off, keys out... With the headlights left on the head unit stays on... Been trying to figure this out for 2+ years now And I've previously attended electrical school for 2 years......Ive come to the conclusion that it is the radio wiring after weeks of playing around. The dashlight wire and illumination wire (from car harness) are the key i think but havent figured it out yet. dashlights were out but after playing with those wires they are now working (not properly) but I can see speed and parking lights stay on. test for power on the dashlight and illumination wire from the cars wiring harness, cant remember which one but one has 12v and is not normal for it to have power.It should be supplied power from illumination wire on head unit. Radio did once work with aftermarket head unit with out these problems Took out Pioneer unit that came in car from previous owner. lights worked fine. Didnt like it and put alpine unit in now have problems. Maybee try changing head unit.????? no clue at this point but good luck. Come up with any solution please reply.... EMAIL:juliecourt1@comcast.net
court24 is offline  
post #3 of 4 Old 11-20-10, 09:04 PM
Registered User
Join Date: Feb 2010
Posts: 5
this same thing happened to me my mechanic figured it out and it turned out a controller module blew out somewhere in my car and it got replaced and they worked
maximus329 is offline  
post #4 of 4 Old 01-02-13, 09:26 AM
Registered User
Join Date: Dec 2012
Posts: 1
Dashlights don't work

[QUOTE=maximus329;1628684]this same thing happened to me my mechanic figured it out and it turned out a controller module blew out somewhere in my car and it got replaced and they worked[/QUO

Hey man do you know which controller module blew?
Jdallday is offline  
Sponsored Links

  Acura Forum : Acura Forums > Luxury Sedans > TL > 2nd Gen TL

Quick Reply

Register Now

In order to be able to post messages on the Acura Forum : Acura Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome

Ad Management plugin by RedTyger