I bought a ticking Legend - Acura Forum : Acura Forums

2nd Gen Legend Model year 1991-1995 Acura Legend, Coupe and Sedan.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-11-09, 11:23 PM Thread Starter
Registered User
 
Join Date: May 2009
Posts: 2
I bought a ticking Legend

I bought a 92 Legend sedan cheap and hoping it doesn't take too much to get it running right. The engine runs smoothly with no missing except for loud ticking. We had a 91 Accord that ticked a little but this one is loud. Could anyone give me an idea what I am dealing with? Thanks for any help!
3rdman is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-11-09, 11:38 PM
Banned
 
Duckdog's Avatar
 
Join Date: Apr 2006
Location: The Old West
Age: 58
Posts: 30,197
Have the valve lash adjustment done. Piece of cake.
Duckdog is offline  
post #3 of 4 Old 05-11-09, 11:42 PM Thread Starter
Registered User
 
Join Date: May 2009
Posts: 2
Thanks for the onfo. I was hoping that might be the problem but I am usually not that lucky. I will have to find someone as i have never done it on a multi-valve.
3rdman is offline  
post #4 of 4 Old 05-12-09, 08:35 PM
Prez of Acura-Holiks club
 
L3GDKANG's Avatar
 
Join Date: Jan 2007
Location: 10-A-Key
Posts: 178
My Mood: Relaxed
Quote:
Originally Posted by duckdog View Post
Have the valve lash adjustment done. Piece of cake.
Not so easy!
Quote:
Originally Posted by 3rdman View Post
Thanks for the onfo. I was hoping that might be the problem but I am usually not that lucky. I will have to find someone as i have never done it on a multi-valve.
our cars take a special tool for that and not many places carry this tool as its used on the legends! 1st check the oil you might have to runs some thinker 10 30 oil in it. might have to add lucis to it as well.

Just a few of my JDM pieces! I'm moding my sedan after the Alpha and the Alpha Touring Honda Legends but with a custom twist to it!
L3GDKANG is offline  
Sponsored Links
Advertisement
 
Reply

  Acura Forum : Acura Forums > Luxury Sedans > Legend > 2nd Gen Legend

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Acura Forum : Acura Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome