I bought a ticking Legend - Acura Forum : Acura Forums
Acura Forums Acura Forums
 
Go Back   Acura Forum : Acura Forums > Luxury Sedans > Legend > 2nd Gen Legend


2nd Gen Legend Model year 1991-1995 Acura Legend, Coupe and Sedan.

Reply
 
LinkBack Thread Tools Display Modes
Old 05-12-09, 12:23 AM   #1 (permalink)
Registered User
 
Join Date: May 2009
Posts: 2


Car 1: 05 F150
Car 2: 00 Wrangler
Car 3: 92 Acura Legend
I bought a ticking Legend

I bought a 92 Legend sedan cheap and hoping it doesn't take too much to get it running right. The engine runs smoothly with no missing except for loud ticking. We had a 91 Accord that ticked a little but this one is loud. Could anyone give me an idea what I am dealing with? Thanks for any help!
3rdman is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Old 05-12-09, 12:38 AM   #2
Banned
Lifetime Supporting Member
 
Duckdog's Avatar
 
Join Date: Apr 2006
Location: The Old West
Age: 56
Posts: 30,197


Car 1: '05 SSM TL
Car 2: 2005 Honda Pilot EXL
Car 3: 94 Integra LS
Have the valve lash adjustment done. Piece of cake.
Duckdog is offline   Reply With Quote
Old 05-12-09, 12:42 AM   #3
Registered User
 
Join Date: May 2009
Posts: 2


Car 1: 05 F150
Car 2: 00 Wrangler
Car 3: 92 Acura Legend
Thanks for the onfo. I was hoping that might be the problem but I am usually not that lucky. I will have to find someone as i have never done it on a multi-valve.
3rdman is offline   Reply With Quote
Old 05-12-09, 09:35 PM   #4
Prez of Acura-Holiks club
Supporting Member
 
L3GDKANG's Avatar
 
Join Date: Jan 2007
Location: 10-A-Key
Posts: 178
My Mood: Relaxed


Car 1: 91 jdm ka7 alpha/at
Car 2: 92 jdm ka8
Car 3: 94 ls ka7
Quote:
Originally Posted by duckdog View Post
Have the valve lash adjustment done. Piece of cake.
Not so easy!
Quote:
Originally Posted by 3rdman View Post
Thanks for the onfo. I was hoping that might be the problem but I am usually not that lucky. I will have to find someone as i have never done it on a multi-valve.
our cars take a special tool for that and not many places carry this tool as its used on the legends! 1st check the oil you might have to runs some thinker 10 30 oil in it. might have to add lucis to it as well.
__________________
Just a few of my JDM pieces! I'm moding my sedan after the Alpha and the Alpha Touring Honda Legends but with a custom twist to it!
L3GDKANG is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Acura Forum : Acura Forums > Luxury Sedans > Legend > 2nd Gen Legend


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



Auto Insurance

» Featured Product
Wheel & Tire Center

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 10:34 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
(c) Acuraworld 2006-2009. All rights reserved. Some likenesses, images, and the Acura logo are (TM) American Honda Corporation.Ad Management plugin by RedTyger