New Member with a Legend 97 - Acura Forum : Acura Forums
New Member Introductions New to the site? Let us know a little about yourself and your car.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-02-19, 08:03 PM Thread Starter
Registered User
 
Join Date: Mar 2019
Posts: 3
New Member with a Legend 97

Hi,

I'm a proud owner of a Legend 97 with 60k miles and it's a stock unit, I don't like to modify my cars. I have other cars in my garage but for me this one it's special, I love it!

I hope to learn and share my thoughts with all of you.

Thank you.
javito is offline  
Sponsored Links
Advertisement
 
Reply

  Acura Forum : Acura Forums > Featured Forums > New Member Introductions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Acura Forum : Acura Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Member, New (OLD) Legend owner. Starlord New Member Introductions 0 06-12-14 06:31 PM
New Member Here (97 Integra GS) andytonetti New Member Introductions 7 08-29-10 02:52 PM
New member...have questions re: 91 Legend LOONIZUNILOVER New Member Introductions 0 03-26-10 02:07 PM
New Member - 97 3.2TL Base czmg22 New Member Introductions 14 10-11-08 09:03 PM
FS: 95-97 v6 accord/ 97 cl 3.0 neuspeed springs sd97cl Aftermarket Parts and Accessories 1 11-18-06 02:47 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome