Check Engine light has me paranoid - Acura Forum : Acura Forums
RSX Forum related to the Acura RSX

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 08-09-08, 07:28 PM Thread Starter
OMGRSX
 
Botulism's Avatar
 
Join Date: Jun 2008
Location: Louisville, KY
Age: 30
Posts: 67
Check Engine light has me paranoid

ok, yesterday, for no apparent reason (i wasnt driving it hard and everything felt perfectly fine) my check engine light came on when i started it up. As i was driving, everything felt fine, nothing out of the ordinary, but my light still stayed on. later last night i met some friends out of town, and had my car off for a good twenty minutes or so, but when i got ready to leave, i turned the car on and the light was still on.

however, after about 5 minutes or so of driving, the light just went off as i was going down the road. i figured that the problem or fluke was over and was greatful there wasnt any problem, apparently. I woke up this morning, turned the car on normally, and it was fine. just an hour or so ago i started it up again to go somewhere and the light turned on again. i havent done anything to the car and it still feels like it drives, handles, and shifts perfectly fine.

WTF is going on!! as most of you know i have had a looong history with this car despite having it such a short time, so i am (at least i think) understandably freaking out about my car's well-being.
Botulism is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old 08-09-08, 10:12 PM
Banned
 
Duckdog's Avatar
 
Join Date: Apr 2006
Location: The Old West
Age: 61
Posts: 30,196
Get the code read.

My guess? A slight misfire. Might be running some tank residue or whatnot after the accident you had.



You might also have a loose fuel line that is pulling a little air.
Duckdog is offline  
post #3 of 18 Old 08-10-08, 11:04 AM
AW's Resident Smartass
 
TireMeltingRSX's Avatar
 
Join Date: Jun 2005
Location: Phoenix, AZ
Age: 38
Posts: 38,577
My Mood: Cheeky
Send a message via AIM to TireMeltingRSX Send a message via Yahoo to TireMeltingRSX
go and get it checked out. Have them read the code to determine the problem. I think you can even go to autozone to have them read the code, but don't quote me on that.




2006 VBP RSX Type S
TireMeltingRSX is offline  
 
post #4 of 18 Old 08-10-08, 04:44 PM Thread Starter
OMGRSX
 
Botulism's Avatar
 
Join Date: Jun 2008
Location: Louisville, KY
Age: 30
Posts: 67
yea, autozone does do free scans, but i wasnt able to take advantage of it...because the light went off on the way there. they said it will only send out info if the light is on, so i just talked to em about it. they said if it is doing something like that, it isnt a very serious problem, if one at all. they said it could mean its just time for a tune up, spark plugs, or battery. (97k miles now)

odds are it is the battery or something because the previous owners never changed the battery. one, because it never quit, and two because the standard 5 year replacement stuff didnt really happen till i got it. so i was planning on chaning the battery anyway sometime soon. hopefully that is all.
Botulism is offline  
post #5 of 18 Old 08-11-08, 10:01 AM
AW's Resident Smartass
 
TireMeltingRSX's Avatar
 
Join Date: Jun 2005
Location: Phoenix, AZ
Age: 38
Posts: 38,577
My Mood: Cheeky
Send a message via AIM to TireMeltingRSX Send a message via Yahoo to TireMeltingRSX
I'd still try to get them to read it if it comes back on. I had the problem with my old RSX where it came on, and went off, and came back on and I took it to get looked at... and it was hydrolocked




2006 VBP RSX Type S
TireMeltingRSX is offline  
post #6 of 18 Old 08-11-08, 10:23 AM
 
Join Date: Aug 2008
Posts: 30
Mine was on when i was buying the car. Turned out it was the O2 sensor.
D0RIKIN is offline  
post #7 of 18 Old 08-11-08, 02:07 PM Thread Starter
OMGRSX
 
Botulism's Avatar
 
Join Date: Jun 2008
Location: Louisville, KY
Age: 30
Posts: 67
Quote:
Originally Posted by TireMeltingRSX View Post
I'd still try to get them to read it if it comes back on. I had the problem with my old RSX where it came on, and went off, and came back on and I took it to get looked at... and it was hydrolocked
yea, i definitely plan to check it out. if it comes on again, i will try to get to an autozone or whatever as fast as i can, before it goes off again, lol.

hopefully it isnt hydrolocked....cuz then that would kind of suck...a lot.
Botulism is offline  
post #8 of 18 Old 08-11-08, 02:10 PM
AW's Resident Smartass
 
TireMeltingRSX's Avatar
 
Join Date: Jun 2005
Location: Phoenix, AZ
Age: 38
Posts: 38,577
My Mood: Cheeky
Send a message via AIM to TireMeltingRSX Send a message via Yahoo to TireMeltingRSX
Yeah, I doubt it is, I'm just saying if it continues to come on I'd get it checked out just to be safe




2006 VBP RSX Type S
TireMeltingRSX is offline  
post #9 of 18 Old 08-19-08, 01:06 PM
 
Join Date: Jun 2006
Posts: 9
well if the ecu hasnt been reset, usually the code is still stored even with CEL off.
ToFu is offline  
post #10 of 18 Old 08-19-08, 03:08 PM Thread Starter
OMGRSX
 
Botulism's Avatar
 
Join Date: Jun 2008
Location: Louisville, KY
Age: 30
Posts: 67
well its been about a week and the light hasnt come back. must have just been some small glitch or fluke, all i can assume.

but i am always prepared to head up to autozone if it ever comes on again.
Botulism is offline  
post #11 of 18 Old 08-19-08, 06:14 PM
 
Join Date: Jun 2006
Posts: 9
you are at about 97k miles rite? might want look into getting a new O2 sensor (primary) known problem that it goes out from 30k-100k miles. same symptoms as my friends 02 type-s when he hit 89k miles
ToFu is offline  
post #12 of 18 Old 10-08-08, 11:51 AM
 
Join Date: Oct 2008
Posts: 3
Check the gas cap- I know it sounds stupid but sometimes a loose gas cap will set off the sensor- tighten it down past 3 clicks and then see what happens- if it was the cap the check engine light should go off after a few driving trips
Boosk6 is offline  
post #13 of 18 Old 10-09-08, 04:27 PM Thread Starter
OMGRSX
 
Botulism's Avatar
 
Join Date: Jun 2008
Location: Louisville, KY
Age: 30
Posts: 67
Had the light checked out a couple weeks ago, turns out it is the O2 sensor. However, lately it as been off for almost a whole week so i think it is ok. I am still planning on replacing the sensor though.
Botulism is offline  
post #14 of 18 Old 10-09-08, 05:20 PM
AW's Resident Smartass
 
TireMeltingRSX's Avatar
 
Join Date: Jun 2005
Location: Phoenix, AZ
Age: 38
Posts: 38,577
My Mood: Cheeky
Send a message via AIM to TireMeltingRSX Send a message via Yahoo to TireMeltingRSX
Good idea




2006 VBP RSX Type S
TireMeltingRSX is offline  
post #15 of 18 Old 10-11-08, 01:58 AM
Old Parts Slinger
 
C25A1guy's Avatar
 
Join Date: Dec 2002
Location: Burbank, CA
Age: 35
Posts: 9,604
Garage
Send a message via AIM to C25A1guy
if its intermittent like that, my best and most logical guess would be a P1166. Primary AF Sensor Heater Failure. Next on the list would be fuel cap.

-Dean
C25A1guy is offline  
Sponsored Links
Advertisement
 
Reply

  Acura Forum : Acura Forums > Luxury Coupe / Hatchback > RSX

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Acura Forum : Acura Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Ad Management plugin by RedTyger