Acura Forum : Acura Forums - Reply to Topic
1st Gen RL Forum for the 1996-2004 Acura RL

Thread: DTC Codes for Acura RL Reply to Thread
Title:
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces)
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Acura Forum : Acura Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
09-18-12 04:59 PM
jjmenei Hi All,
P0141 (secondary O2 Sensor) did fail. After replacement, my check engine light has not illuminated for the past week. I think I am good to go. Just wanted to close the loop on my O2 sensor issue. By the way, this sensor is located on the Catalyst converter.
08-24-12 04:39 PM
jjmenei I rechecked my Shop Manual & P0141Trouble code is the sensor as you stated. Secondatry H02S, thanks for you comprehensive list.
08-22-12 10:24 PM
jjmenei Hi petthepeep, I have a DTC of P0141, but I am confused where the o2 sensor located. The Helm service manual indicates it is a Right Hand "Primary" o2 Sensor located on the RH exhaust manifold. You are indicating it is a "secondary " Heated Oxygen Sensor Heater Circuit Malfunction (Sensor 2) which is attached to the Catalyic converter? Can you set me straight? Thank you Jim at: [email protected]
07-25-12 12:44 PM
MeanFace My ABS,SRS, and TCS lights are on.
The code we got is P0151. They (Acura of Valley Stream) said its O2 sensor bank 1 but the codes listed here state its Bank 2 Sensor 1.

Which one is it ?
How difficult is it to do myself ?
06-25-11 11:09 AM
boljangles Thanks for this list!
06-24-10 02:37 PM
jeffs3000 An OBDII reader will not reset these codes.

The ABS and TCS codes are part of the DTC (diagnostic trouble codes) which you read by hooking up a paper clip to a blue connector underneath the passenger glove box, then read the blinking patterns on the ABS and TCS lights. These codes are not part of the MIL codes (malfunction indicator lamp or check engine), which are typically P---- codes, which are the codes read by an OBDII reader. I own an OBDII reader which has come in handy very many times. This awesome tool will do nothing for the TCS codes I want to reset, as the MIL and DTC are seperate (think of it as two different computers).
The procedure for resetting these codes on newer RL's involves holding one or more buttons and the brake for X number of seconds while turning on the ignition, or something crazy like that.

If anyone else knows how these TCS codes are reset, please chime in, Thanks!
06-23-10 02:02 PM
dallison if you have an obd-II reader you can erase them
06-21-10 05:32 PM
jeffs3000 Does anyone know how to reset the TCS codes on a 1996 ACura RL?

I was able to reset the ABS codes, but I tried removing the battery for an hour and the TCS codes are still there.

Anyone know how to reset these codes?

Thanks for any info!
04-23-10 04:40 AM
tam85 denso brand was really awesome!!
11-23-09 09:14 PM
jedigecko1 Thanks, but by the time I got this reply, I had already replaced the O2 Sensor with a Denso Brand replacement. Perfect fit. But my advice would be for others to try cleaning the Original malfunctioning O2 sensor with a commercial product available at NAPA. Might work the first time.
11-22-09 04:30 PM
gaffster That refers to your O2 sensor just behind the catalytic converter.

Borrow the O2 socket from AutoZone, etc. get under the car and remove.

Easiest to solder old wiring from under the passenger seat through the floor' I solder under the car, so I don't have to mess with the seat. Pretty easy.
07-07-09 10:33 PM
jedigecko1 I have an 02 and the Check Engine Light is on. When I scan with an OBD, the DTC that I'm getting is reading P0141= 02 Heater Circuit (Bank 1, Sensor 2). Any suggestions on how to DIY to correct this? BTW Pics would help.
01-07-09 02:44 PM
giltexex I have an 02 and am getting codes 132 and 152 bank 1 and bank 2 as well as 1457.

Any thoughts on any other underlying issues causing the 132 and 152 codes to come on? I have noticed that when I fill up the car it sputters while I drive out of the station. In fact it will cut off.
04-25-08 09:57 PM
HenryT My abs light comes on after a few minutes of driving or it either comes on right at startup.I just went to read the codes and i got 1-8 for the ABS.It's a 1996 RL premium model with TCS, heated seats, etc. Any idea as to what i should do or what is causing this and how to repair it.
02-08-08 12:37 AM
louieginzo
Quote:
Originally Posted by sciam2000 View Post
I seem to be recieving a code of 1-5 from my ABS light. One long and five short. Any ideas? The car is a '99 RL with 130,000 miles.

The ABS light stays on constantly. When I drive the car the TCS light comes on. The codes I recieve from TCS are 5-4 and 6-1. Does this make any sense?
Any assistance you can provide is greatly appreciated.

Kind regards,

Ross

yes mine does the same also when i start my car up no lights are on...
as soon as i move the abs light goes on
i have 90k miles and i got intake and catback muffler i dont know what it can be but it never gave me a problem yet....but i hate seein that light
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome
 

Ad Management plugin by RedTyger