Acura Forum : Acura Forums - Reply to Topic
RSX Forum related to the Acura RSX

Thread: Check Engine light has me paranoid Reply to Thread
Title:
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces)
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Acura Forum : Acura Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-16-18 06:17 AM
Shivanibhut22 wow, great
05-05-18 10:14 PM
văn nghĩa i like you, that is good idea!!
08-26-17 07:29 PM
Mik I have a 2002 Acura RSX (base model) automatic. It has a modified exhaust and a AEM cold air intake. Problem is engine light keeps coming on, and after replacing the evap vent valve, and the eval pressure valve, it bogs at 4000 RPM. Prior it was running great. I drive it hard through the outmatch/tiptronic gears. shifting by rPM. Any suggestions?
10-11-08 01:58 AM
C25A1guy if its intermittent like that, my best and most logical guess would be a P1166. Primary AF Sensor Heater Failure. Next on the list would be fuel cap.
10-09-08 05:20 PM
TireMeltingRSX Good idea



10-09-08 04:27 PM
Botulism Had the light checked out a couple weeks ago, turns out it is the O2 sensor. However, lately it as been off for almost a whole week so i think it is ok. I am still planning on replacing the sensor though.
10-08-08 11:51 AM
Boosk6 Check the gas cap- I know it sounds stupid but sometimes a loose gas cap will set off the sensor- tighten it down past 3 clicks and then see what happens- if it was the cap the check engine light should go off after a few driving trips
08-19-08 06:14 PM
ToFu you are at about 97k miles rite? might want look into getting a new O2 sensor (primary) known problem that it goes out from 30k-100k miles. same symptoms as my friends 02 type-s when he hit 89k miles
08-19-08 03:08 PM
Botulism well its been about a week and the light hasnt come back. must have just been some small glitch or fluke, all i can assume.

but i am always prepared to head up to autozone if it ever comes on again.
08-19-08 01:06 PM
ToFu well if the ecu hasnt been reset, usually the code is still stored even with CEL off.
08-11-08 02:10 PM
TireMeltingRSX Yeah, I doubt it is, I'm just saying if it continues to come on I'd get it checked out just to be safe



08-11-08 02:07 PM
Botulism
Quote:
Originally Posted by TireMeltingRSX View Post
I'd still try to get them to read it if it comes back on. I had the problem with my old RSX where it came on, and went off, and came back on and I took it to get looked at... and it was hydrolocked
yea, i definitely plan to check it out. if it comes on again, i will try to get to an autozone or whatever as fast as i can, before it goes off again, lol.

hopefully it isnt hydrolocked....cuz then that would kind of suck...a lot.
08-11-08 10:23 AM
D0RIKIN Mine was on when i was buying the car. Turned out it was the O2 sensor.
08-11-08 10:01 AM
TireMeltingRSX I'd still try to get them to read it if it comes back on. I had the problem with my old RSX where it came on, and went off, and came back on and I took it to get looked at... and it was hydrolocked



08-10-08 04:44 PM
Botulism yea, autozone does do free scans, but i wasnt able to take advantage of it...because the light went off on the way there. they said it will only send out info if the light is on, so i just talked to em about it. they said if it is doing something like that, it isnt a very serious problem, if one at all. they said it could mean its just time for a tune up, spark plugs, or battery. (97k miles now)

odds are it is the battery or something because the previous owners never changed the battery. one, because it never quit, and two because the standard 5 year replacement stuff didnt really happen till i got it. so i was planning on chaning the battery anyway sometime soon. hopefully that is all.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome
 

Ad Management plugin by RedTyger