Acura Forum : Acura Forums - Search Results
Advanced Search
Showing results 1 to 4 of 4
Search took 0.01 seconds.
Search: Posts Made By: Mimi74
Forum: RSX   08-31-18, 01:36 AM
Replies: 1
Views: 1,125
Posted By Mimi74
It might be the started or a sensor I had this...

It might be the started or a sensor I had this problem and I read in another forum to put the car in neutral then try to start it and it started right up it hasn’t happened since
Forum: New Member Introductions   08-31-18, 01:26 AM
Replies: 3
Views: 511
Posted By Mimi74
Hello There I drive a 05 RL It has 180,000 and still runs great, No major issues just

2005 Rl Navigation Issues
Hello I was wondering if anyone has had problems with the Navi system the screen went blank and I cannot use some of the buttons like the menu, disc player and AC also my...
Forum: Ask The Dealer   08-31-18, 01:21 AM
Replies: 0
Views: 717
Posted By Mimi74
2005 Acura RL Navigation System Issues

2005 Rl Navigation Issues
Hello I was wondering if anyone has had problems with the Navi system the screen went blank and I cannot use some of the buttons like the menu, disc player and AC also my...
Forum: Acura news feeds...   08-31-18, 01:16 AM
Replies: 0
Views: 642
Posted By Mimi74
2005 Rl Navigation Issues

Hello I was wondering if anyone has had problems with the Navi system the screen went blank and I cannot use some of the buttons like the menu, disc player and AC also my AC is not coming on I’m not...
Showing results 1 to 4 of 4

 
Forum Jump
 
For the best viewing experience please update your browser to Google Chrome
 

Ad Management plugin by RedTyger