Acura World banner

vsa

  1. Code p2138 but not the App sensor or tps (Throttle body)

    3rd Gen TL
    Lil backstory, Ive had my 05 acura TL base for close to 3 years now and In that short time I've replaced the transmission with a rebuilt one, all new genuine transmission sensors/solenoids etc. Replaced speed sensor, pcm repaired, motor/transmission mounts, valve cover gaskets, tuned it up and...
  2. VSA/ABS Lights after doing EGR/Intake Cleanup

    1st Gen RL
    Really hoping someone can help out with this. My Car is a 2002 Acura RL with Navi I recently did the EGR + Intake cleaning procedure to get rid of P0401 engine light. The procedure went great, a lot of gunk build up and had clogged the passage. However, the moment I turned my car back on...
  3. VSA lights on after car sits 4 months

    2nd Gen TL
    I recently made a dumb mistake and let my Acura TL sit for several months without driving it. And of course it didn't want to start up when I tried to drive it. After putting in a brand new battery it would start but then stall out, I had to keep my foot on the gas pedal or it would turn off and...
  4. SH-AWD, VSA, and ABS aren't working on '07 MDX...

    MDX
    There are several issues with my MDX... I am fortunate enough to know someone that owns an on-board diagnostic scanner, but they have no idea what these codes indicate the problem to be. Obviously, the SH-AWD, VSA, and ABS aren't working, I am wondering what the problem could be or if you've had...
  5. VSA, ABS and yellow/!\

    Ask The Dealer
    Hello, newbie to the forum thing but a big DIY guy. I bought a 2004 TL and it was pulling to the right so I took it into a shop and they said I needed to replace the right passenger side lower control arm and the steering knuckle. Probably the cause of the steering was the previous owner slid...
  6. Ham Radio and VSA

    2nd Gen RL
    I have a strange thing going on and I wanted to see if anyone else had the problem. I am an amateur radio operator and have a VHF/UHF transceiver in the 2000 Acura RL. When I transmit on VHF (i.e., not UHF) on HIGH power, the VSA light and the little exclamation point come on AND the...
  7. ABS VSA <!> lights on

    1st Gen RL
    2000 Acura RL Started the car Saturday morning after it sat a day (hot, humid, and a little rain). Within 100 ft the ABS, VSA, and <!> lights came on. No noticeable performance change. Turn the car off, back on, the lights went away for a few minutes, then all back on. Hooked up my handy dandy...
Top