Acura World banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So for the past 2 weeks my check engine light has been either "flashing" or "solid" went to Advanced Auto to have them check the codes and it says RANDOM MISS FIRES on all cylinders except 2 and 5. Made sure my gas is spot on. All cylinders fire while at rest but as soon as you accelerate then the misfire occurs BUT once up to speed the engine fires on all cylinders. I replaced ALL my Ignition coils about 2 years ago so I doubt if that the issue. It seems that it like a SPARK advance issue OR I am thinking that it might be the MAF sensor for my KD CAI system. There is NO fuel filter since it is all in the gas tank and VERY RARELY would require replacement. I have cleaned and checked the air intake manifold and gasket GTG. So do I think
1. MAF sensor
2. spark advancement
3. fuel injectors

Anyone? Bueller?:spit:
 

·
Registered
Joined
·
4,812 Posts
I'd start by "rolling back the clock" as it were, and reinstalling the OEM parts. No use in going any further with the diagnosis until you're certain that the aftermarket parts didn't cause the issue.
 

·
Registered
Joined
·
138 Posts
I'd start by "rolling back the clock" as it were, and reinstalling the OEM parts. No use in going any further with the diagnosis until you're certain that the aftermarket parts didn't cause the issue.
right...:loser:
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top