Acura World banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
i have a 07 acura tl so both head gaskets were blown so i decided to replace the engine the guy at the engine place told me the engine i bought was a direct fit after i installed it and noticed small differences with the plugs on the harness and come to find out my engine was a j32a3 the one i put in is a j37a4 everything got connected and it turns over and acts like it wants to start but it wont completely start, possiably the timing ?
 

·
Registered
Joined
·
99 Posts
i have a 07 acura tl so both head gaskets were blown so i decided to replace the engine the guy at the engine place told me the engine i bought was a direct fit after i installed it and noticed small differences with the plugs on the harness and come to find out my engine was a j32a3 the one i put in is a j37a4 everything got connected and it turns over and acts like it wants to start but it wont completely start, possiably the timing ?
hi bro hope every thing was fine from your side, as per your question you should be first finde the history of the engine form which car it was related so of thing would be missing you have to find all the history of it from the vin decoder i think it would be give you better idea from it
 

·
Registered
Joined
·
1 Posts
Hey bro I did the same thing I replace my j35a8 with a j37a4 with the dual vtec system. I had to switch the oil pump, and change the cam gears the one in front that the camshaft sensor readsa nd don't forget to do a valve clearance afterwards.
 
1 - 4 of 4 Posts
Top