Acura World banner
1 - 8 of 8 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My Rdx has 88k and I’ve owned since 61k and this is my only issue that just started. Randomly after driving, could be 3 min or 39 the AWD warning comes on, and “”CHECK AWD SYSTEM” when vehicle is restarted it’s off, possibly for the next drive or 2 days later. Seems more prominent with colder weather but only thing I can point out. I have yet to change diff fluid but don’t want to do unless a possible fix. Would prefer to avoid dealer.

Thank you in advance.
 

· Registered
Joined
·
112 Posts
My Rdx has 88k and I’ve owned since 61k and this is my only issue that just started. Randomly after driving, could be 3 min or 39 the AWD warning comes on, and “”CHECK AWD SYSTEM” when vehicle is restarted it’s off, possibly for the next drive or 2 days later. Seems more prominent with colder weather but only thing I can point out. I have yet to change diff fluid but don’t want to do unless a possible fix. Would prefer to avoid dealer.

Thank you in advance.
A little checking found this similar situation:

UPDATE: Diagnosis complete and apparently the fault lead to the aft differential motor pump. Internal wiring check carried out on the motor pump assy. and found a lead with no continuity. Acura ordered a whole motor pump assy, and will be replaced once the part arrives. I hope this is only a one off occurrence! Will update once the repair is complete. In the mean time I'm driving around with the AWD light illuminated.

Definitely has to go to a dealer!
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top