Acura World banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi -

I posted this on a different forum (rl.acurazine.com) a few days ago but no responses so I'm hoping for better luck here.

Gang -

Tonight I was driving along ('96 Acura RL) when there was a very bad electrical smell. Then the following symptoms:

- gauge lights got VERY bright - especially speedo numbers
- could not adjust them via dash light brightness controller
- speedo stopped working (and needle not iluminated)
- needles on gas & temp gauge move but not illuminated
- tach was working but needle not illuminated
- dash light brightness controller did work for lights in center of dash like radio and A/C (but not for instrument panel)
- no odometer display
- car runs fine
- battery and alternator voltage are fine
- dash dimmer control checks out fine with ohmeter

I have checked all the under hood fuses but have a few more to do under the dash.

The car still stinks from whatever burned up.

Looking at the shop manual to see what all these symptoms have in common leads me to the gauge assembly. I've seen a few on ebay in the $250 range.

Ideas? Thanks.

Bob
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
7/24/12/ update

Well, I pulled out the Instrument Panel (IP) and the 'bad smell' is definitely coming from within. So I guess my next step is to purchased a used one and give it a try.

Tugging on some of the plastic trim pieces is a little nerve wracking since it feels like they are going to break. The shop manual is a big help.

I imagine there is someway to take my old odometer module and put it into the used unit that I buy. But if the 'new' one works I'm somewhat loath to take it apart.

The car runs but no IP (speedo, tach, gauages, warning lights) or radio or A/C. If I get stopped the cop will think I stole it!

I tried to post a couple of pictures that I had uploaded to acuraworld dot com but got the following error:

You are only allowed to post URLs to other sites after you have made 15 posts or more.

Since the URLs were to this site not sure why the error.
 

Attachments

·
Registered User
Joined
·
35 Posts
mine also burned up. i lost the speedo and the odometer but the other guages continued to work. i also got a puff of smoke when the cluster burned up and could smell it for a day or so inside the cabin.

i have been using a GPS to monitor speed, but safety check is coming up and i need to replace the cluster in order to pass the check and renew registration.

cluster is about 250 online (used only) and dealer will install for 200.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Alohamonte -

Join the club. I got one from a bone yard in VT. Any cluster from '96 - '04 will work. Some of the graphics and lights changed a little in '99 but they are still plug compatible. My 'new' one was from an '01 and it worked great. $75 plus S&H and I was able to put it in myself. That was a deal. Plus it took 81K off my odometer so I feel like I have a new car.

For grins I looked at my old one. It looks like a PC motherboard inside. I would not have a clue about where to start in trying to fix whatever fried.

Best of luck!

Bob
 
1 - 4 of 4 Posts
Top