Acura World banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I'm on my 3rd Acura. My '05 TL had BT handsfree, but it just didn't work well, so I unpaired it. Now I have a '10 with tech. I expected Acura to improve how this system works. So far, that doesn't seem to be the case.

I'm using an iPhone 5. Placing calls through the car's phone menu is such a pain that I prefer to dial on the phone directly. When the call starts, it says it's connected to HF Link, but when the other person picks up the call goes to the phone. When I try to switch the call back to HF link it takes two times selecting HF Link on the phone before the call actually switches to the car. This whole process takes 10+ seconds, which is a long time to have the person on the other end yelling "HELLO?"

Is this just the norm on current gen Acuras? I just came from a BMW and that BT system worked wonderfully! Calls would go to the car whether I dialed from the car or from the phone directly. This is what I expect with all HF BT devices actively connected.

Is there a better way to set this up?
 

·
Registered
Joined
·
21 Posts
odd... I have a 2010 TL with tech package and I have blackberry. The initial pairing took some trial and error but it's always automatically re-paired when ever I get in the car. I've found calling to be OK--but then again the audio/phone/map controls in the TL are very complicated. i'm surprised I've not crashed while trying to pick a number from the phonebook. I've also imported my phones phonebook into the onboard phonebook--that makes things a bit easier.

I've heard iPhones are very reliable for pairing and blackberry is the worst.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top