Acura World banner
1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Having a couple issues with my 91 ls.....I recently replaced the blower motor due to the fact none of my fans were working...also had to replace the blower motor resistor because after replacing the motor all I had was high. My current issue I can not get the windshield to defrost properly. In all other cars I've driven I let the car warm up turn defrost on once the windshield is clear im good to go never have any issues again. In my ls I turn on the defrost setting and put it on the none recirc setting and the windshield barely clears up. Later on while I'm driving it seems to kick in and defrosts the window then turns off. Windshield fogs up again. Any ideas? Also driver side and passenger side window defrosts just enough I can see into the side mirrors. Second issue is leaking water on the passenger side. Its not as bad as it was before I replaced the blower moter but I'm still getting water dripping in. Any help would greatly appreciated.
 

·
Registered
Joined
·
4,830 Posts
If the water is clean, it's coming from topside. If it's dirty, it's coming from underneath. Since yours is an LS, it's got a factory moonroof. Clogging or rotted drain tubes could be a reason for water leakage (they're made out of rubber).

To trace the water leak, dry the area completely, and sprinkle baby powder all over the footwell, including the side panels and as far up as you can get. The leak trail will become evident in the powder, and make it easier to diagnose the source.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top