Acura World banner
1 - 3 of 3 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I've owned my 08 TL-S for about a month now, and I have this annoying "click, click" sound when I take off from a stop. I will also hear the clicking noise sometimes immediately after I remove my foot from the brake pedal. I also hear the clicking sound when I am pulling into my driveway right after I hit the curb. It is the same noise every time. I am sure it is not the brakes, I just installed a set of new pads and was sure to install the shim plates as well. The sound almost seems to be coming from the center of the engine bay. I'm thinking CV axle. However the click coming as soon as I release the brake pedal kind of says otherwise. If anyone else has experienced this noise, please leave me some feedback, I do not wan't to change the axles if this is not the issue. Car drives perfectly fine, no vibration or anything like that.
 

· Registered
Joined
·
13 Posts
Me too....

I’ve got the same annoying click. What did you do to fix it? I can’t find any solution and the dealer wants waaayyy too much.
I had a similar annoying click usually on acceleration. I started tightening bolts all over the struts, brakes, and suspension, no improvement. Finally I took my car to Turbo Tim's, he tightened the subframe bolts and I think that fixed the problem.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top