Acura World banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
This is my very first swap and i've ran into a few issues so far i was hoping for some pointers on. I have a 92 acura integra ls with a b18a1 that i just pulled out. I picked up a 90 civic hatch that slid into a telephone pole for a few hundred bucks. It has a b20b and ys1 gsr transmission and was very well kept. It ran like a beast in the civic but obviously my teg has a much nicer body so i figured i'd swap. So far the problems i have ran into are as follows. Once i got the b20 in the teg the drivers side motor mount wouldn't line up. I fixed this problem by pulling the motor mount bracket of the b18 block and putting on the b20 then using the mount from the teg. The next problem which is one of the biggest so far is 98% of my wiring doesn't match up in the teg now. most of the connectors are on the opposite side of the car from what i can tell and won't reach far enough to plug into anything properly. Do i need to swap wiring harnesses from something else and if so what? Or what is another easy fix to get everything plugged in properly? The next issue i've noticed so far is the header from the b20 won't fit as the bar below the radiator in the teg (cross member if im correct maybe) is in the way of the pipe, i had to pull it off in order to get the motor into the car and there's not enough room between the engine and that bar for the pipe to come up through, obviously i'll have to use another header and i'm assuming the one off the b18 will fit for the time being until i can pickup a nicer one am i right? also do i need to swap the computer out of the civic as well? someone told me since i'm changing motors i need to pull the computer out of the civic and put in the integra as well? Another big problem i ran into was getting the b**** pin out of the tranny in the civic so i just took the bolt out of the shift linkage cable for the time being and meant to knock the b**** pin out while the motor was out of the car...lol i forgot until it was bolted into the integra, and i obviously don't have a special tool to remove it, so i still need to knock that out so the cable in the teg will hook into the new tranny because the cable in the teg does NOT have a bolt i can take out like the civic did. Any advice on an easy diy method to remove the b**** pin without a special punch? Also i realized the drivers side axle is different on the teg as well, as one end has a male tip and the other a female, that i fixed by building a custom axle out of 2 as a buddy at autozone suggested. That's about the extent of my swap progress so far as i'm stuck on the wiring issue for the time being as well as the computer question. Thanks in advance for any help and tips and is there anything i did not mention that i might also run into as i progress? I would ultimately like to have the teg up and fully running within the next 2 days as i've already been without wheels for about 5-6 days now and i have the next 2 days off work to get this finished. Thanks again and sorry for the book This is my first swap and i'm egar to get the b20 up and running fully in the teg.
 

·
AW Detailing Wanker
Joined
·
16,287 Posts
Pneumatic hammer and a 7mm (I think) punch to remove the pin. Ive done it with a regular hammer but its a huge pain.
 
1 - 3 of 3 Posts
Top