Acura World banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I think I need a new hard drive. Every few days my Nav screen will be black with a message that says (from what I recall) "Application Error. Unable to initialize." I think that is what is says. Down in the right hand corner there is little number 6 displayed. I can't access anything that uses the screen such as audio settings or Nav/map. Luckily this car does display the a/c info and radio station on the radio screen. If I restart the car it will often come on correctly, but not every time.

I have a 2010 TL with Nav. About 50k miles. Is this diy for someone who is slightly handy, but by not close to being a mechanic? Is it the hard drive failing? Seems like something Acura should fix as it should not fail with such low miles.
 

·
Registered
Joined
·
4,830 Posts
Let's get in to the vehicle's diagnostic mode:

Start the vehicle, and at the disclaimer screen use the navigation display hard buttons:

Press and hold the MAP/GUIDE, MENU, and CANCEL, buttons for about 3 seconds. The display screen goes directly to the Select Diagnosis Items menu shown.

Self-Diagnosis Mode (runs the automatic diagnosis of the navigation system)

Detail Information & Setting (Can help you to manually diagnose the navigation system)

See what you can see there, and report back when you can :)
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top