Acura World banner

1 - 5 of 5 Posts

·
Brian
Joined
·
9 Posts
Discussion Starter · #1 · (Edited)
03 MDX - Help, Navigation display is down. Not actually trying to use the navi system and the display unit seems to be working but it’s not loading the screen, it just displays "Please check your disk"

I’m guessing it’s the alpine based DVD./ROM unit under the passenger seat. I’ve checked the connections on it, checked the fuses, removed the battery terminals (in case some reset was needed) I am not able to eject the Navi DVD from the unit.

I know this runs a Windows CE environment for the entire display screen, not just the Navi portion. If I remove the power connector from the DVD unit the screen goes blank, when I put it back in I get Please check disk.

Here’s how it started. DVD started with disk read errors on Navi functions some time ago. Everything else worked fine. Found disk was scratched, odd b/c in 155K miles I never had it out before. Anyway, in anticipation of reming the unit to clean it I removed the connectors to verify everything came out nice and easy and put them back in. Now unit throws this message. All connectors are seated firmly.

Is there any sort of hard boot option or process to get this thing restarted?
I have the 03 MDX factory service manual but there is NOTHING on the Navigation or display system.

All comments and opinions welcome! Right now I have no heater functions other than the temp and on/off control.

Thanks,
Brian
 

·
Brian
Joined
·
9 Posts
Discussion Starter · #2 ·
Seems that the DVD based unit under the seat may not be getting power or responding to power.

Anyone know the pinouts on the harness going into the unit so I can see if it's getting 12v? The 2 thousand page service manual has nothing on this unit.

Anyone know if there is a specific fuse or relay that feeds this thing?

Anyone know of a source for rebuilt or used units?
 

·
Brian
Joined
·
9 Posts
Discussion Starter · #4 ·
Thanks Tim. I believe C1 pin should indicate whether unit was receiving power, it was. the DVD fan and disk eject are not working. Unity appears to be bad.

After reviewing some older threads I saw a reference to Alpine service. Here is some new detail on how we can get our units serviced.

Apline will service Acura OEM units.
Goto dubdubdub.alpine-usa.com/support/service
and call 800 832-4101 They will replace/repair whatever is wrong with the until for a flat $358 fee. This includes return shipping. It is a large increase from the $158 fee posted earlier but still much better than any 4 figure amount for a new unit.

Turnaround time is supposed to be 5-7 business days once they receive it. I'll repost with my experience.

Thanks again for your help, I was beginning to wonder if there were any wrenches in the forum.


Brian
 

·
Brian
Joined
·
9 Posts
Discussion Starter · #5 ·
Quick update to Alpine service

Just wanted to follow-up on my earlier issue. Alpine shipped the Nav unit pack exactly on the time they quoted in a very secure very reusable protective package. The unit worked like new with none of the previous issues. The repair was worth every penny !!

Unfortunately I traded the MDX in a few weeks ago and won't enjoy the unit any longer. Good luck with your NAV issues.

Brian
 
1 - 5 of 5 Posts
Top