Acura World banner

1 - 20 of 21 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
i replaced my stereo and the dash light stopped working. i had a shop look at to make sure the dimmer wasnt the problem and they checked everything to do with the stereo and dash. i also checked the connectors in the dash and there all connected.

any ideas?
 

·
**** Whore
Joined
·
10,142 Posts
Did you check all the fuses? There are 3 fuse boxes on the 2nd Gen TL. Driver's side front door well, passenger side door well, under the hood passenger side.
 

·
**** Whore
Joined
·
10,142 Posts
Also, which lights stopped working? Just the ones in the speedometer cluster or the ones for the air conditioner / navi as well?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
ive checked all three fuse boxes. my dash cluster, climate control, and shifter lights dont work, but when my head lights are off the climate control light works until you turn on the lights it goes off
 

·
**** Whore
Joined
·
10,142 Posts
I'm assuming you replaced your stereo with an aftermarket unit?

Sounds like the wiring was not done right..
 

·
**** Whore
Joined
·
10,142 Posts
They might have blown all the bulbs when they were doing the installation. The easiest light to get to to test out would probably be the shifter light. Take a flathead and pop off the plastic trim around the shifter. Take off the diffuser thing and the light is under there.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
i just checked and its fine. the clock and climate light work but when i turn the light over they shut off, could it have something to do with the lights?
 

·
Registered User
Joined
·
3 Posts
I have the same probelm, aftermarket stereo installed, my dash lights worked when i picked the car up that night.

next night my dash lights didnt work and my tail lights wont work at night when the head lights are on, but the brake lights do work.

I check the driver's side fuse box, it looks like fuse 9 is the fuse that manages all this, but it wasn't blown.

Any ideas?

Please help!
 

·
Tastes minty
Joined
·
7,324 Posts
I have the same probelm, aftermarket stereo installed, my dash lights worked when i picked the car up that night.

next night my dash lights didnt work and my tail lights wont work at night when the head lights are on, but the brake lights do work.

I check the driver's side fuse box, it looks like fuse 9 is the fuse that manages all this, but it wasn't blown.

Any ideas?

Please help!
There's another fuse that controls all that in the fusebox located under the hood at the center rear of the engine bay, right up against the firewall. I forget the number but they're labeled. I guarantee you it's that one.
 

·
Registered User
Joined
·
3 Posts
Bro, that was it, I can't thank you enough, I was only looking at the fuses on the drivers side door area.

I had to go through each one acura labeled that fuse "small lights".

If you're ever in New York I owe you a beer.
 

·
Registered
Joined
·
1 Posts
Hello....i have 2000 Acura 3.2 tl and i just installed aftermarket radio and the dash light stopped working...i checked the fuse in all 3 location and they are all fine....and also spend $50 and changed the dimmer switch and still its not working....I also checked the connections and that is fine...dont know what else to do....If someone can give me the fuse number under the hood just to make sure...

PLEASE I NEED YOUR HELP
 

·
Registered
Joined
·
1 Posts
There's another fuse that controls all that in the fusebox located under the hood at the center rear of the engine bay, right up against the firewall. I forget the number but they're labeled. I guarantee you it's that one.
Do you think you could elaborate??? Another fuse box??

Ill Explain my situation....

So I need some MAJOR Help. I was taking apart all the plastics around the shifter (just for fun) and found the light bulb for lighting up the P N R D ect. and thought it would be a great idea to throw in an LED. BUT, I accidentally short circuited the wire and I watched sparks fly off the wires and all my instrument panel lights shut off. And my running lights don't work (break lights work but not tail lights and parking lights)

It seems like this would be a fuse problem, but I'm pretty sure I looked through all the fuses, (I'm going to check them all later today again) Is there Something else I'm forgetting to check? Seems like it could be fuse 9 but that wasn't blown. I've read other things on re-soldering the "DRL module" but I am pretty sure this is a blown fuse.

Oh and this morning the SRS Light came on, seems like that is definitely related to crossing the wires, I know how to fix that but I really really REALLY need this fixed as SOON as Possible!!!!!
 

·
Registered
Joined
·
15 Posts
We are having the same problem with a friends car, Hope you find the problem, personaly i think the stock stereo has the resistor that runs the dash light dimmer switch
 

·
Registered
Joined
·
3 Posts
I have similar problem. My rpm, speedometer fuel/temp gauge lights don't work as well as left turn signal light on dashboard. I replaced all 3 fuses, replaced all the bulbs. Every other light works. I heard a pop under the hood by the firewall few nights ago. Could it be a resistor/condencor? I need some info.
 

·
Registered
Joined
·
3 Posts
It's is definitely of the fuse under the hood if you go and you look at your fuse box it'll say small light fuse located inside the fuse box it will be a 15 amp fuse. Once replaced all your lights should come back on that were not working
 

·
Registered
Joined
·
3 Posts
Also before replacing the fuse you may want to check your wires to make sure they are taped off properly or connected properly with butt connectors if not then you'll have the same problem all over again. The copper wires cannot be showing otherwise it could lead to blowing the fuse
 
1 - 20 of 21 Posts
Top