Acura World banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have an 06 Acura TL 5At . The thing is that it was driving fine and then one day going down the parkway it fell out of gear, I had to pull over and put it in park then into drive again. A week later it started going to shift gears neutral out then slam into gear so I babied it. Then it progressed to falling out of gear and catching its self slam into gear. It grinds when going from drive to reverse or park. Now I drive it in manual and it works shifts and everything I am not able to drive it in auto. The orange triangle is up and my vsa light is on for a 84-1 code and it says sensor logic failure Abs/vsa control unit will quit communication above 30 mph that’s all it says. The fluid is clean as a whistle the trans has over 170k I have no idea what the problem could be please help.
 

·
More horsepower, please?
Joined
·
15 Posts
Hello!
My 2004 TL was nearly perfect in every way. Then, at about 170k, the trans started acting a little funny. I took it to my mechanic ASAP. The fluid was clean, but smelled burnt. After his research on the problem, he discovered that most 3rd gen TL transmissions fail at about 120k mi. Acura designed the 3rd gen TLs with insufficient transmission fluid coolers. My mechanic turned my car over to a capable local transmission shop. That shop was familiar with our TLs problem. A rebuilt trans was ordered from Southern Cali, and shipped to Cedar Performance and Transmission in Cedar City, UT. The ‘new’ transmission was installed, with a new, appropriately sized cooler.
That work, along with one new motor mount, was $5100.
Sorry!
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top