Acura World banner
1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hey guys,

My check engine light came on this morning :( (it solid not blinking) I believe it has something to do with the emissions sensor's. I have a 99 TL w/ 60k on it. I have had most of the services done for the 60k maintenance. I called the dealer this morning to get a ballpark figure for the cost of fixing. All he could tell me was that it is $90 to get the diagnosis. He would not give me ballpark for parts or anything. :dunno: My question is has anyone had this done to their car? If so about how much was it to fix? Also, if I get the readout and they quote me something ridiculous is it feasible to take some repair shop and tell them the problem and let them fix or just leave it to the dealer to rape me on the cost??? :bigcry:

Any help on this would be greatly appreciated.
If I do take to a repair shop, anyone know a good one in MD

Thanks,

Eric
 

·
Registered
Joined
·
3,825 Posts
Originally posted by e_meyers
He would not give me ballpark for parts or anything. :dunno:
That's usually how it works...they can't give you a price on how much something is going to cost if they don't know what need fixing.

Are you sure it's your check engine light and not your maintence required light?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Yeah it's the check engine light. From reading the owners manual I thought that it said it was most likely an emissions sensor. I in no way know how many sensors there are so i was just hoping that he could give me a ballpark figure for it if it was one of those sensors. I guess it could still be something else. Oh well though I'll be taking it in on Monday.
 

·
Bling_Bling INSPIRE 32V
Joined
·
3,018 Posts
Just like Johnny said, you must have them diagnose first and find out what's wrong.
 

·
Jack This
Joined
·
2,318 Posts
This happened to me after 100 miles. My car was brand new (still is, kinda => only 3k miles now).

There are a couple things you can fix here. Have you checked your gas filler cap? This is the biggest culprit. You really need to make sure it's on tight. At least 3 clicks. If you got gas recently, this is probably the problem. But will take some time driving for it to go away.

If it is a sensor, it could be like what happend to mine. I had a bypass valve stuck open. However, I was still under warranty. Second day of ownership.

Cost can be a couple hundred bucks is my guess.

baggs
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top