Acura World banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey folks, I couldn't find a post that had this same topic, and didn't see something on other sites about this. I wonder if anyone has had the same process.

We have a 2008 RDX/tech package.

Very occasionally, when we start the car, the nav screen does nothing--it doesn't appear to boot at all, and remains blank. If we turn the car off, and then restart, the screen tends to work. So it's never been something that has "stuck."

But, it's very frustrating, and we're worried that one day it will stop working completely and turning the car off and on won't work. And we don't want to be stuck somewhere we need the Vani and not have it work.

Acura techs said they hadn't heard of it, and that we should bring it back when it's not working. Which of course requires that when it happens, we have time to take it in. Not ideal,

Has anyone had a similar problem, or do you have thoughts as to what could be the problem?

Thanks
 

·
Moderatus Emeriti
Joined
·
22,190 Posts
:welcome: to AW.

Best suggestion would be to post this question in the "Ask The Dealer" Forum. Tim monitors that and is a great resource from the Dealer's persepctive (as well as being a real nice guy!)

And stop back around and introduce yourself in the New Members Thread!

:beerchug:
 

·
Registered
Joined
·
33 Posts
I have heard from another RDX owner that he had his Nav DVD reader replaced it had gone bad and had the same issues also with the loading at start up . Now after replacing it's working fine . Also there are firmware upgrades that the dealer has to fix any bugs and updates .
 

·
Registered
Joined
·
188 Posts
Both are correct.

There are multiple solutions to that problem. Updating the software if applicable is one.

The other could be with the navigation control unit. It may be scratching the DVD and causing the delay. Fix = new unit and DVD.

The dealer should know this. Thats unexcusable.
 

·
Registered
2008 RDX w/Tech Package
Joined
·
1 Posts
Yup, very similar to "nchoya92"

We have a 2008 RDX/tech package.

Occasionally, when we start the car, the nav screen does nothing--it doesn't appear to boot at all, and remains blank. If we turn the car off, and then restart, the screen tends to work. So it's never been something that has "stuck."

But, it's very frustrating, and we're worried that one day it will stop working completely and turning the car off and on won't work. And we don't want to be stuck somewhere we need the Nav and not have it work. In our case the screen is more likely to be blank now than even three years ago.

Acura techs said they hadn't heard of it, and that we should bring it back when it's not working. Which of course requires that when it happens, we have time to take it in. Not ideal, a dismissive answer.

This problem occurred early on when the vehicle was still on warranty but I have had this vehicles to FOUR different Acura dealers and ALL of them said " they hadn't heard of it " and can't fix it without seeing it. No one in 12 years suggested a patch or fix. Except to replace the screen and computer unit. But that costs more than the Tech option in the first place!

We really like our 2008 RDX, it is hanging in there, looks good, and has had all the maintenance requirements fulfilled.

Is there any more information that would help us?

Cheers.
 
1 - 6 of 6 Posts
Top