Acura World banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I recently replaced all 4 struts on my 97 RL with new KYB's. Old struts literally fell apart when taking them off after 136K miles. The new struts have been on for about 8 months and once again I am feeling a lot of the road, at times bottoming out on small bumps and in general feeling like the struts are shot again. So my question is should I have replaced the springs when replacing the shocks? Seems to me that all of the load would have transferred to the springs when the shocks failed so I am thinking they may be shot or sagging. Thoughts? Anyone have any suggestions as to were to buy springs other than the dealer?

Also, I had replaced the main relay last year when the car suddenly died on me. However, I now have no courtesty internal door lights or visor lights. I have checked all the fuses and everything is OK. I recently took the car to get inspected and the shop told me they could not get codes from the car so there must be a short or a blow fuse. Has anyone experienced this and if so, can you point me in the right direction as I have to get this fixed. May end up having to take it to the dealer and this can get pricey chasing gremlins.

Thanks in advance for any help.
 

·
Old Parts Slinger
Joined
·
9,587 Posts
It's pretty rare that the springs would require changing. Did you DIY the install or had someone do it for you?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Yes it was a DIY project as I had researched it extensively prior and am fairly decent with repair work. The car was sitting for over a year in extreme cold up north after being a Texas car. When I got around to needing it again I also had to replace all 4 rotors which had warped, new brakes, rear sway bar bushings, outer tie rods, upper ball joints and the CV Axles. It was if the entire suspension had fallen apart during that year.

Given that the shock part of the struts was so bad it seems to me the load would have fallen completely to the springs hence my concern they too may have gone. My thought was that the car is now riding with little if no spring support.

I bought the new KYB stuts from RockAuto and they seem to have a good track record from everything I have read so I am hard pressed to belief the new trusts are bad after only 8 months. My concern now is are they getting worse daily IF the coils are going or gone.
 

·
Old Parts Slinger
Joined
·
9,587 Posts
Try compressing the suspension and see if the shaft goes through the strut mount. It shouldn't poking it's way through except for the threaded area. If it is, disassemble and you're probably missing a washer somewhere in the assembly.
 

·
Cajun Gumbo Man
Joined
·
916 Posts
I read somewhere that if not done properly you get the results you are referring too.....I wish I could find that thread....I had brought my 04 RL in for service FOR A FIRST TIME 8 years later.....they rotated the tires and I read something about if it "sits" for a long time this can occur.....hope this helps!
 
1 - 5 of 5 Posts
Top