Acura World banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have 04 TL changed timing belt buttoned it all back up and started hearing this sound hard to explain maybe like a flapping sound nevertheless started looking and noticed alot of slack in my belt around the waterpump which wasn't there when I installed belt counterclockwise starting at crank.... only things I can figure are I wasn't on compression stroke when I was TDC and rear cam spun forward on me while putting belt on...does anyone know why I have excessive play in my belt around water pump? Thanks
 

·
Registered
Joined
·
103 Posts
I have 04 TL changed timing belt buttoned it all back up and started hearing this sound hard to explain maybe like a flapping sound nevertheless started looking and noticed alot of slack in my belt around the waterpump which wasn't there when I installed belt counterclockwise starting at crank.... only things I can figure are I wasn't on compression stroke when I was TDC and rear cam spun forward on me while putting belt on...does anyone know why I have excessive play in my belt around water pump? Thanks
You are doomed.

Did you pull the pin on the belt tensioner?

You best not be driving this until you get everything re-timed lest the engine go boom.

Astrobuf
 

·
Registered
Joined
·
134 Posts
Did the belt tensioner give up the ghst? Timining belt procedure usially requires replacement of the belt tensioner, water pump and belt! Once replaced you should manually crank the engine to verify belt searting and timing is correct. These are zero clearance engines don't run it!
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
yeah.... I'm shopping for a new engine.... either way it was time, I'm right at 300,000 and I learned that next time I'll just pay someone to have it done. I have a partial spare motor to pick from now I guess. Thanks anyways guys 😔
 
1 - 4 of 4 Posts
Top