Acura World banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I currently drive an 04 TL, and lately my brake lights would come on along with my engine light and the VSA indicator light while I'm driving. once this happens, my car will automatically slow down and feel as if it is jerking while still pressing on the gas like it wants to speed up but wont, and once I brake my car will brake harder than usual. This has happened to me last week and the next morning my engine light went away once my car was started for a few minutes, this weekend the same thing happened and then went away the next morning although it happened again today twice. Usually when this happens I pull over and restart my car to get rid of the brake lights and the check engine light will be the only one that is left, but when I drive the car it still feels hesitant while pressing on the gas. The check engine light will come on while driving but then go back away once in awhile. I did go to autozone for a diagnostics check and got five codes back, I don't really want to go to the dealership since it will take a long time just to get an appointment in... so any ideas on what it could be? I would post the codes but they are currently in my car. Although I do remember that most of the codes were about my APP sensor, circuits and something about the air flow or air sensor.
 

·
Courierbird
Joined
·
1 Posts
I had same problem with 2004 acura tl . I would be driving along and VSA light comes on and car slows and doesn't respond to pressing on accelerator. I replaced the APPS (Accelerator pedal position sensor). This took care of the problem I am pleased to say. I replaced it myself not hard to do at all. go to youtube pull up Accelerator pedal position sensor 2005 Acura TL this will take you to a video showing you how to replace APPS. Hope this helps you.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top